Skip to content

[GHSA-jx5v-788g-qw58] katello SQL Injection vulnerability - #10881

Closed
jasnow wants to merge 2 commits into
jasnow/advisory-improvement-10881from
jasnow-GHSA-jx5v-788g-qw58
Closed

jasnow wants to merge 2 commits into
jasnow/advisory-improvement-10881from
jasnow-GHSA-jx5v-788g-qw58

Conversation

@jasnow

@jasnow jasnow commented Nov 4, 2026

Copy link
Copy Markdown

Updates

  • Affected products
  • Description
  • References

Comments
Work on fhis advisory can be found at:
rubysec/ruby-advisory-db#1275

Copilot AI auto review requested due to automatic review settings November 4, 2026 18:56
@github-actions
github-actions Bot changed the base branch from main to jasnow/advisory-improvement-10881 November 4, 2026 18:57

Copilot AI left a comment

Copy link
Copy Markdown
Contributor

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

🟡 Changes recommended

The advisory still has an incorrect fixed version that misreports Katello 3.5.0 as vulnerable, along with a remaining grammatical error in its description.

2 open issues
What changed in this PR

Updates the Katello SQL injection advisory with revised version metadata, description text, timestamps, and an upstream fix reference.

Changes:

  • Refines the affected-version range and fixed-version metadata.
  • Removes the outdated vulnerability statement.
  • Adds the relevant Katello upstream commit reference.
  • Corrects the advisory description wording.

This pull request requires changes.

File Summary Findings
advisories/​github-reviewed/​2022/​05/​GHSA-jx5v-788g-qw58/​GHSA-jx5v-788g-qw58.json Updates advisory details, version ranges, metadata, and references. Set the fixed version to 3.5.0 instead of 3.6.0.rc1; correct the grammatical error in the description.

Review effort: Lite (auto)

},
{
"last_affected": "3.10"
"fixed": "3.6.0.rc1"
],
"summary": "katello SQL Injection vulnerability",
"details": "A SQL injection flaw was found in katello's errata-related API. An authenticated remote attacker can craft input data to force a malformed SQL query to the backend database, which will leak internal IDs. This is issue is related to an incomplete fix for CVE-2016-3072. Version 3.10 and older is vulnerable.",
"details": "A SQL injection flaw was found in katello's errata-related API. An authenticated remote attacker can craft input data to force a malformed SQL query to the backend database, which will leak internal IDs. This is issue is related to an incomplete fix for CVE-2016-3072.",
@jasnow

jasnow commented Nov 4, 2026

Copy link
Copy Markdown
Author

was not able to edit the file so closing this PR

@jasnow jasnow closed this Nov 4, 2026
@github-actions
github-actions Bot deleted the jasnow-GHSA-jx5v-788g-qw58 branch November 4, 2026 19:19
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Labels

None yet

Projects

None yet

Development

Successfully merging this pull request may close these issues.

2 participants